Elevated Error Rates for Receipts / ECOMM APIs
Incident Report for flexEngage
Resolved
Upstream issues with impacted services have been resolved and platform stability has been restored.
Posted Dec 08, 2021 - 04:16 UTC
Monitoring
A fix has been implemented and is being monitored AWS-side, and we continue to experience improvements in the stability of our services. We will be monitoring ongoing and will provide further updates as the situation changes.
Posted Dec 07, 2021 - 22:44 UTC
Update
While issues with AWS persist, the impact on the affected services has started to abate. We are currently seeing improved reliability across all impacted services. However, until the issue is considered resolved on the AWS side, our team will continue to monitor and mitigate wherever possible.
Posted Dec 07, 2021 - 22:10 UTC
Identified
The issues being experienced on our platform are a direct result of a known AWS outage. Our team is continuing to monitor the situation and look for ways to mitigate impact.
Posted Dec 07, 2021 - 17:55 UTC
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 16:46 UTC
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 16:45 UTC
Update
We are continuing to experience elevated error rates due to an AWS outage and are reviewing the impacted services. The current impacts are as follows:
* Receipts API experiencing elevated error rates
* Order Status (ecomm) API experiencing slow response times
* Receipt and order/ecommerce notifications are delayed
* Shipment tracking page (flexTracker) experiencing slow response times and elevated error rates
* You may experience issues accessing sent Order Status (ecomm) messages in our app
* Email Validation API has been removed from the list of impacted services
Posted Dec 07, 2021 - 16:44 UTC
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 16:16 UTC
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 15:59 UTC
Investigating
We are experiencing elevated error rates for Receipts and ECOMM APIs. We are currently investigating the issue.
Posted Dec 07, 2021 - 15:59 UTC
This incident affected: Receipts (API, Notifications), Ecomm (API, Portal, Notifications), and Webhooks (Webhook Event Delivery).