Email Validation Issues

Incident Report for flexEngage

Resolved

The issue has been resolved
Posted Sep 22, 2023 - 12:45 UTC

Monitoring

The issue was caused by issues with an upstream service provider. The service provider has mitigated the issue and we have seen an improvement. We believe the issue is mitigated and we will continue too monitor the status.
Posted Sep 22, 2023 - 12:35 UTC

Investigating

Email Validation services are currently validating the majority of emails with an unknown status. We are investigating the issue.
Posted Sep 22, 2023 - 11:22 UTC
This incident affected: Receipts (Email Validation).